22
Ноя

Динамической проброс портов на Mikrotik (вариант 1)

Что делать когда у Вас динамический белый ip, а нужно как-то пробросить порты через Mikrotik и использовать какие либо устройства в Вашей внутренней сети.
На помощь приходит небольшой скрипт erazel

Добавляем скрипт в System – Scripts , например с именем NAT Kyivstar

Вначале добавляем проброс портов, по обычной схеме
Chain: dstnat
Dst. Address: наш динамический IP (например от Киевстар Украина)
Dst. Port: 4899 — порт который будет доступен из интернет
Action: dst-nat
To Addresses: 192.168.0.20 — локальный ip внутренней сети Mikrotik
To Ports: 4899 — порт внутренней сети Mikrotik

После чего создаем комментарий записи: Comment: radmin
На каждую последующую запись делаем свой комментарий

После того как создали записи, добавляем скрипт в System – Scripts , например с именем NAT Kyivstar

:global ddnsip [ /ip address get [find interface="ISP1"] address ]
:for i from=( [:len $ddnsip] - 1) to=0 do={
:if ( [:pick $ddnsip $i] = "/") do={
:set ddnsip [:pick $ddnsip 0 $i];
}
}
/ip firewall nat set [find comment="radmin"] dst-address=$ddnsip
/ip firewall nat set [find comment="CAM-1"] dst-address=$ddnsip
/ip firewall nat set [find comment="CAM-2"] dst-address=$ddnsip
/ip firewall nat set [find comment="CAM-1 rtsp"] dst-address=$ddnsip
/ip firewall nat set [find comment="CAM-2 rtsp"] dst-address=$ddnsip
/ip firewall nat set [find comment="CAM-2 ONIF"] dst-address=$ddnsip
/ip firewall nat set [find comment="CAM-1 sdk"] dst-address=$ddnsip

После чего добавляем в System – Scheduler задание с именем NAT Kyivstar и выбираем желаемый интервал выполнения.