22
Ноя

no-ip.org как динамический DNS на Mikrotik

Сервис динамического обновления ip адреса для Ваших доменов от no-ip.org
Сразу предупреждаю что этот сервис для бесплатной работы, будет засыпать Вас письмами для продления. Не нажали на ссылку, перестанет работать.

И так сам скрипт:

:local ddnsuser «[email protected]»
:local ddnspass «PASS»
:local ddnshostname «satsis.no-ip.org»
:local ddnsinterface «ISP2»

:global ddnslastip [:resolve $ddnshostname];
:global ddnsip [ /ip address get [find interface=»ISP2″] address ]
:if ([ :typeof $ddnsip ] = «nil» ) do={
:log info («ServiceDNS: No ip address on $ddnsinterface .»)
} else={
:for i from=( [:len $ddnsip] — 1) to=0 do={
:if ( [:pick $ddnsip $i] = «/») do={
:set ddnsip [:pick $ddnsip 0 $i];
}
}
:if ($ddnsip!=$ddnslastip) do={
:log info («ServiceDNS: $ddnshostname -> $ddnsip»)
:global str «/nic/update?hostname=$ddnshostname&myip=$ddnsip»
/tool fetch url=»https://dynupdate.no-ip.com/$str» mode=http user=$ddnsuser password=$ddnspass \ dst-path=(«/ServiceDNS.».$ddnshostname)
:global ddnslastip $ddnsip
}
}

:local ddnsuser «[email protected]»
:local ddnspass «pass»
:local ddnshostname «satsis.no-ip.org» — Ваш домен
:local ddnsinterface «ISP2» — интерфейс с динамическим ip