27
Ноя

eoip-tunnel с динамическими ip адресами

Задача следующая. У Вас в распоряжении динамический белый ip адрес, но необходимо поднять между двумя Mikrotik eoip-tunnel
Привязываете к Mikrotik доменное имя на сервере с динамическим DNS: Cloudflare, DynDNS или no-ip
Добавляем скрипт в System – Scripts , например с именем eoIP


Освоить MikroTik вы можете с помощью онлайн-курса «Настройка оборудования MikroTik». В курсе изучаются все темы из официальной программы MTCNA. Автор – официальный тренер MikroTik. Материал подходит и тем, кто уже давно работает с оборудованием MikroTik, и тем, кто еще не держал его в руках. В состав входят 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.


:global hosteoIP «Ваше доменное имя динамического DNS»
:global resolvedIP «»

/ip dns cache flush
:local eoIP [/interface eoip get [/interface eoip find tunnel-id=»номер туннеля» ] remote-address];
:set resolvedIP [:resolve $hosteoIP];

:if ($resolvedIP != $eoIP) do={
:log info («eoIP: Updating IP, setting $hosteoIP = $resolvedIP»)
/interface eoip set [/interface eoip find tunnel-id=»номер туннеля»] remote-address=$resolvedIP;
/ip dns cache flush
} else={
:log info «eoIP: No Update Needed!»
}

После чего добавляем в System – Scheduler задание с именем eoIP и выбираем желаемый интервал выполнения.