15
Дек

Хостим персональный сайт на Mikrotik

Итак, мы имеем зарегистрированное доменное имя, «белый» статический ip-адрес и маршрутизатор Mikrotik RB751G-2HnD c замечательной функцией MetaRouter. Начнём с выбора образа openwrt для нашего маршрутизатора. Зайдём на роутер через программу winbox и посмотрим на его архитектуру. У модели RB751G-2HnD архитектура mipbse:

Хостим персональный сайт на Mikrotik


Скачиваем с сайта последний образ openwrt для mipbse отсюда. Копируем на роутер в Files:

Хостим персональный сайт на Mikrotik_2

Импортируем образ openwrt в метароутер, и добавляем сетевой интерфейс для нашего виртуального образа:

/metarouter import-image file-name=openwrt-mr-mips-rootfs-31411-basic.tar.gz memory=24 enabled=yes
/metarouter interface add virtual-machine=mr2 type=dynamic dynamic-bridge=bridge_local

Затем входим в консоль образа и первым делом устанавливаем пароль на пользователя root.

Хостим персональный сайт на Mikrotik_3

Редактируем настройки сети для получения сетевых реквизитов по dhcp от самого роутера:

vi /etc/config/network

config interface lan
option ifname eth0
option proto dhcp

Добавляем службу сети в автозагрузку и перезапускаем:

/etc/init.d/network enable
/etc/init.d/network restart

Мы получили сетевые реквизиты, и теперь у нас есть доступ к системе по ssh.

Хостим персональный сайт на Mikrotik_4

Редактируем конфигурационный файл пакет-менеджера для обновления репозитория и установки необходимых программ:

vi /etc/opkg.conf

src/gz snapshots https://openwrt.wk.cz/trunk/mr-mips/packages
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

Далее, обновляем репозиторий и устанавливаем nginx и php:

opkg update
opkg install nginx php5 php5-fastcgi

Переходим к настройке веб-сервера.

mv /etc/nginx/nginx.conf /etc/nginx/nginx_example.conf
vi /etc/nginx/nginx.conf
user nobody nogroup;
worker_processes  1;

error_log  logs/error.log;

events {
    worker_connections  1024;
}

http {
    include mime.types;
    index index.php index.html index.htm;
    default_type text/html;
        
    sendfile on;
    keepalive_timeout 65;
    gzip on;	
    gzip_buffers     4 16k;
    gzip_http_version 1.0;
    gzip_comp_level 2;
    gzip_types       text/plain application/x-javascript text/css application/xml;
    gzip_vary on;
    gzip_min_length  1k;

    server {
        listen	80; # слушающий порт
        server_name  172.16.0.12; # имя или ip-адрес сервера
        fastcgi_connect_timeout 300;
        fastcgi_send_timeout 300;
        fastcgi_read_timeout 300;
        fastcgi_buffer_size 32k;
        fastcgi_buffers 4 32k;
        fastcgi_busy_buffers_size 32k;
        fastcgi_temp_file_write_size 32k;
        client_body_timeout 10;
        client_header_timeout 10;
        send_timeout 60;
        output_buffers 1 32k;
        postpone_output 1460;
        root   /srv/www;		# Папка с файлами сайта
        
        location ~ \.php$ {
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
            include        fastcgi_params;
            
            if (-f $request_filename) {
                fastcgi_pass    127.0.0.1:1026; 
            }
        }
    }
}

Редактируем параметры php:
vi /etc/php.ini

doc_root = "srv/www"
cgi.force_redirect = 1
cgi.redirect_status_env = "yes";

И проверяем параметры fascgi:

vi /etc/nginx/fastcgi_params

fastcgi_param  QUERY_STRING       $query_string;
fastcgi_param  REQUEST_METHOD     $request_method;
fastcgi_param  CONTENT_TYPE       $content_type;
fastcgi_param  CONTENT_LENGTH     $content_length;
fastcgi_param  SCRIPT_NAME        $fastcgi_script_name;
fastcgi_param  REQUEST_URI        $request_uri;
fastcgi_param  DOCUMENT_URI       $document_uri;
fastcgi_param  DOCUMENT_ROOT      $document_root;
fastcgi_param  SERVER_PROTOCOL    $server_protocol;
fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;
fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;
fastcgi_param  REMOTE_ADDR        $remote_addr;
fastcgi_param  REMOTE_PORT        $remote_port;
fastcgi_param  SERVER_ADDR        $server_addr;
fastcgi_param  SERVER_PORT        $server_port;
fastcgi_param  SERVER_NAME        $server_name;

Добавляем службы в автозагрузку и запускаем их:

/etc/init.d/nginx enable
/etc/init.d/nginx start
/etc/init.d/php5-fastcgi enable
/etc/init.d/php5-fastcgi start

Копируем файлы сайта на сервер в указанную папку и проверяем работоспособность сайта внутри локальной сети.
Не забываем поменять http порт нашего роутера и пробросить 80 порт сервера во внешку:

/ip service set port=8080 2 disabled=yes # or no
/ip firewall nat add chain=dstnat action=dst-nat dst-address=внешний_IP-адрес protocol=tcp dst-port=80 to-ports=80 to-addresses=172.16.0.12 in-interface=ether2 disabled=no # in-interface=WAN порт

На этом настройка закончена.

Заключение
Таким образом, мы получили условно (наличие роутера) беслпаный хостинг для персонального сайта с минимальным энергопотреблением и потреблением ресурсов роутера.
Источник: