15
Апр

Dualwan Mikrotik ROS v7.1

Mikrotik ROS v7.1 и два провайдера.

Стартовые настройки
• Интерфейсы в провайдеров добавлены в интерфейс
лист WAN
• Развешаны IP
• Включен masquerading для WAN

# Базовые настройки:

/interface ethernet
set [ find default-name=ether1 ] comment=ISP1
set [ find default-name=ether2 ] comment=ISP2
/interface list
add name=WAN
/interface list member
add interface=ether1 list=WAN
add interface=ether2 list=WAN
/ip address
add address=198.51.100.6/29 interface=ether1
add address=203.0.113.6/29 interface=ether2
add address=192.168.88.254/24 interface=br-lan
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN

Routing tables
# Создать дополнительные роутинг таблицы

/routing table add disabled=no fib name=rtab-1
/routing table add disabled=no fib name=rtab-2

Route defaults

# Добавить дефолты в новые таблицы

/ip route add distance=251 gateway=198.51.100.1
/ip route add distance=252 gateway=203.0.113.1
/ip route add gateway=198.51.100.1 routing-table=rtab-1
/ip route add gateway=203.0.113.1 routing-table=rtab-2

Маркировки (mangle)
# Добавить маркировки

/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=con-isp1 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=con-isp2 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=con-isp1 in-interface-list=!WAN new-routing-mark=rtab-1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=con-isp2 in-interface-list=!WAN new-routing-mark=rtab-2 passthrough=yes
add action=mark-routing chain=output connection-mark=con-isp1 new-routing-mark=rtab-1 passthrough=yes
add action=mark-routing chain=output connection-mark=con-isp2 new-routing-mark=rtab-2 passthrough=yes

При таких маркировках будут работать оба провайдера.
DST-NAT так же будет работать

Route Recursive failover
# Отказоустойчивость через рекурсивные маршруты

/ip route
add distance=251 gateway=198.51.100.1
add distance=252 gateway=203.0.113.1
add gateway=198.51.100.1 routing-table=rtab-1
add gateway=203.0.113.1 routing-table=rtab-2
add dst-address=4.2.2.1/32 gateway=198.51.100.1 scope=11
add dst-address=4.2.2.2/32 gateway=203.0.113.1 scope=11
add check-gateway=ping distance=10 gateway=4.2.2.1 targetscope=11
add check-gateway=ping distance=20 gateway=4.2.2.2 targetscope=11

Route recursive

Route recursive. Fail ISP1

Комментариев нет

Leave a Comment

Обратная связь

    The average number of adverse effects was 3. T max is 23 minutes in females and 32 minutes in males. What other drugs will affect doxercalciferol Viagra natural sin receta. Archived from the original on 2009-08-14.

    Talk to your doctor before using this form of cefadroxil if you have diabetes. What should I tell my healthcare team before starting CABLIVI? There is no FDA guidance on the use of Tetracycline (oral) with respect to specific gender populations https://www.apotheke-rezeptfreie.com/. Opper K, Uder S, Song K Development of Heterogeneous and Homogeneous Platforms for Rapid Analysis of DNA-Protein Interactions.